Isilon OneFS: Timeout or "not found" error when connecting to the SmartConnect zone

Post Reply
chris
Site Admin
Posts: 14
Joined: Mon Dec 09, 2019 6:55 pm

Isilon OneFS: Timeout or "not found" error when connecting to the SmartConnect zone

Post by chris » Tue Aug 25, 2020 2:13 pm

Issue
When you connect to a SmartConnect zone, you receive a "not found" error or the connection times out.

You have installed SmartConnect according to the configuration guide. This means that you have:

Run the isi smartconnect wizard and configured a SmartConnect zone
Created a delegated zone on your DNS server
Configured the IP of the name server for that delegated zone with the virtual IP you configured earlier
Reloaded your name server configuration file
Verification
The following information describes how to verify that SmartConnect is configured and working correctly.

The verification procedures assume the following conditions:

<DNS-IP> is the dotted-quad of the primary domain name server.
<SC-IP> is the dotted-quad of the SmartConnect address assigned to the cluster.
<SC-Name> is the fully qualified domain name (FQDN) of the SmartConnect zone name (for example, test.isilon.com).
SmartConnect is configured with a round-robin policy.
Verify Domain Name Server and SmartConnect Name
From any Unix client machine with recent BIND tools installed (this includes any Isilon node), run the following command:

dig @<DNS-IP> <SC-Name>
This should return an IN A record for test that's the IP of a node in the cluster. Repeat this command several times.

If you receive a new round robbin IP address each time this is run, then SmartConnect is configured properly. Continue with the next verification step.
If you receive no response, the request times out, or get the same IP each time then try reconfiguring SmartConnect on the cluster. See OneFS: How to Configure Windows DNS for a Smartconnect Zone, KB article Link Error 183530.
Verify SmartConnect Zone IP and SmartConnect Name
Run the following command:

dig @<SC-IP> <SC-Name>
This should return an IN A record for test that's a random network node number. Repeat the command several times. You should get different responses each time.

If you receive different responses, then SmartConnect is configured and working and you can continue with the next verification step.
If this test fails, try reconfiguring SmartConnect on the cluster.
Verify NS record
To verify that the NS record on the DNS server is correct, run the following command:

dig @<DNS-IP> +norecurse ns <SC-Name>
This should return the SmartConnect IP address. If the SmartConnect IP address is not returned, the NS record is not correct or not being read. Edit your name server configuration and reload it, then rerun the command to confirm you have solved this problem.

If all of these tests are successful, SmartConnect is configured and working correctly and you are encountering the issue described above.


Cause
BIND DNS servers with forwarding enabled will forward requests for delegated zones to the forwarding server, not to the delegated server. The forwarding server will not request the information from the delegated server and the connection request will return the "not found" error or will time out.

Resolution
Workaround
To work around this issue, disable DNS forwarding for the parent zone containing the SmartConnect delegated zone.

NOTE
See the documentation for your DNS server for instructions on how to complete these tasks.

NOTE
It is recommended to comment out the lines rather than deleting in case you need to revert them back in the future.

Open the named.conf file for the parent zone in a text editor.
In the file, under options, find the forwarders line and the forward only line (if the line exists). The lines look similar to the following:

options {
forwarders {10.0.0.1; 10.0.0.2;};
forward only;
};

Comment out both lines by inserting two forward slash marks in front of each line. The lines will look similar to the following:

options {
//forwarders {10.0.0.1; 10.0.0.2;};
//forward only;
};

Reload the DNS configuration.

Post Reply